CentOS 7 编译安装 PHP 7.4 提示 No package oniguruma found

0 Comment

在编译安装 PHP 7.4 时,如果使用 --with-mbstring 参数,则需要安装 oniguruma。oniguruma 是一个处理正则表达式库,php7.4 中,mbstring 正则表达式处理功能对这个包有依赖。所以,安装 php7.4 前需要安装 oniguruma 和 oniguruma-devel 两个软件包。

一般安装epel 然后安装即可:

yum install -y epel-release
yum install -y oniguruma oniguruma-devel

不行的话就手动安装/更新 epel:

rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
yum install -y https://www.elrepo.org/elrepo-release-7.el7.elrepo.noarch.rpm
yum install -y oniguruma oniguruma-devel

或者:

yum remove epel-release #如果报冲突,先把冲突的包删除
rpm -ivh http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum install -y oniguruma oniguruma-devel
yum clean all && yum makecache
yum repolist all #检查 epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 是否启用

除非注明,垃圾站文章均为网络收集,本文地址 https://cyhour.com/1627/,转载时烦请以链接形式注明原始出处。
声明:我们不销售主机,选主机需合法使用。任何主机需定期备份,防止数据丢失。信息以实际为准,评测仅供参考不代表权威!
🍄:Netflix 奈飞 YouTube 合租

WordPress 4.2+ 使用 Twemoji 替换默认 Emoji 表情

WordPress 4.2+ 新增 Twitter Em❤️ji 表情,但是默认使用的 CDN —— https://s.w.org/images/core/emoji/11.2.0/72x72/ 在国内无法正常访问。解决办法有两个,一是把表情本地化,二是替换掉默认的链接。 🎉 😜 👯 🍻 🎈 🎤 🎮 🚀 🌉 ✨ 使用 Twitter 官方提供 MaxCDN 服务 Twitter 官方提供 MaxCDN 服务…
浏览: 23 标签:  ,  ,  ,  , 

WordPress 随机显示名人格言 + PHP 毒鸡汤

在 编程随想 博客看到个不错的功能——随机显示博主精选的名人格言,稍稍折腾,我也加上了这功能了(在首页随机显示我喜欢的句子)。 :razz: 网上(官网的是英文版的格言)有现成的插件。一个很简单的插件,其实可以集成到 functions.php 去。不过格言也存放在插件的php文件里面,集成到 functions.…
浏览: 98 标签:  ,  ,  , 

Gravatar 头像被墙及解决方案

Gravatar 头像真是一言难尽,时而正常时而抽风时而无法访问……就一个 Gravatar 头像,这有啥好强(现代通假字)的呢?(据说是被其它服务连累?) 解决办法 - 调用 ssl/cn 头像链接 历史解决办法:调用 ssl 头像链接——https还是没被墙的,而且速度还不错,直接调用这个最简单了。主题 functions.…
浏览: 144 标签:  ,  ,  , 
浏览: 111 标签:  ,  ,  , 

Comments:0

发表留言

Vultr 送$100,搬瓦工年付最低$49,优惠码 BWH3HYATVBJW,更多推荐VPS信息