Nginx 启用 FastCGI_Cache 将 WordPress 静态化缓存加速

一年前曾经折腾过 FastCGI_Cache 缓存加速 WordPress,无奈没上线多久,发现 FastCGI_Cache 会把评论者信息和登陆信息缓存,不知道怎么处理掉,只好下线,后来没再折腾。 简介 目前在用 Memcached 数据库缓存,主题做好缓存,数据库查询可以大大减少,一定程度上减少服务器压力,提点速度。提升…
Tags:  ,  ,  ,  ,  ,  ,  Views: 135

OneinStack 搭建 LNMP 安装 Tiny Tiny RSS

一般手机上看 RSS 订阅,Feedly + Reeder 3 用很长时间了,Reeder 4 出来了,非必需品,直接用 Reeder 3 或者 Feedly 也挺好,目前已买,用别人分享账号下载使用更新麻烦。 一直看着别人自建 RSS 服务,想折腾试试,可是一直懒得折腾,目前没有太大需求必须自建,Feedly 目前够用,而且自建稳不稳…
Tags:  ,  ,  ,  Views: 4.3K

LNMP 转换至 OneinStack

博客自用上 VPS 到现在一直在用军哥的 LNMP,一年多了,挺好用的,就是升级 PHP 有点麻烦——升级过程中网站要关闭,完成需要重新安装 Memcached,重新开启 OPCache,配置一下 php.ini…… 而升级 Nginx 就省事多了——自带脚本升级,输入要升级的版本号即可,升级过程中网站可正常访问,升级完就完事。…
Tags:  ,  ,  ,  Views: 1.3K

LNMP 一键安装包 V1.6

最近比较忙,私密了几个标题还没闲心填坑。星期六,上班稍闲,水一篇刷刷存在感。 PHP 5.6.x 停止安全支持 2018年12月31日,PHP 5.6.x 安全支持正式停止。不过,2019.1.10 官方发布最后一个安全更新版本:PHP 5.6.40,如果没有发现严重漏洞,这将是 PHP 5 最后一个版本。(言下之意是可能还会更…
Tags:  ,  ,  ,  Views: 1.3K

OneinStack 自动安装体验

用 VPS 以来一直使用 LNMP 搭建网站环境。LNMP 1.5 也支持自动安装,不过 OneinStack 有交互界面生成安装命令,复制执行即可。加上想尝尝鲜,于是在新买的 Aulerion VPS 上体验了一把。 OneinStack 自带自动安装配置 lnmp(Linux + Nginx+ MySQL/MongoDB+ PHP) lamp(Linux + Apache+ MyS…
Tags:  ,  ,  ,  ,  Views: 1.7K

LNMP 1.5 使用 OpenSSL 1.1.1 开启 TLSv1.3 支持

以前使用 OpenSSL 1.1.1 dev draft-18 开启过 TLSv1.3,那时候浏览器都得手工开启才支持 TLSv1.3,所以基本上纯属自娱自乐。八月份 TLS 1.3 正式发布,九月份 OpenSSL 1.1.1 正式版…… Chrome 70+ 版本默认开启 TLS 1.3 Final 支持;Firefox 63+ 也默认支持…… 博友 kn007 大佬折腾 TLS 1.3;可乐…
Tags:  ,  ,  ,  Views: 1.7K

搬瓦工 VPS 利用 Snapshots 快速搬家

双十一忍不住剁手买了搬瓦工2018年11.11特别促销款——2G 内存 / 2x CPU / 40G SSD / 1T 流量 / KVM,使用优惠码后仅需 $29.88。 剁手后就寻思着如何快速将博客搬家到新 VPS 上,甚至,在外面玩的时候用手机安装好 LNMP。 但是,搬家还是挺烦人——Memcached 需要重新安装配置、OPcache 也需要重新…
Tags:  ,  ,  ,  ,  ,  ,  ,  Views: 2K

Nginx 开启 Gzip 压缩加速 WordPress

Gzip(GNU-ZIP)是一种压缩技术。经过 Gzip 压缩后页面大小可以变为原来的 30% 甚至更小,用户浏览页面速度会快很多。Gzip 压缩页面需要浏览器和服务器双方都支持——服务器端压缩,传输至浏览器解压并解析。 Nginx 压缩输出有一组 Gzip 指令来配置,相关指令位于http{….}两个大括号之间。LNMP 默认已…
Tags:  ,  ,  ,  Views: 943

LNMP PHP 多版本共存使用教程

此教程只适合 LNMP1.4 版本以上一键脚本,并且 LNMP PHP 多版本共存只支持 LNMP 模式,不支持 LNMPA、LAMP模式! LNMP 安装 PHP 多版本 在 lnmp1.5 源码目录下运行: ./install.sh mphp 按提示选择要另外安装的PHP版本,不能多选,只能选一个,要安装多个需要安装完成后再运行前面的安装…
Tags:  ,  ,  ,  Views: 1.3K