标签: PHP 7.4

CentOS 7 编译安装 PHP 7.4 提示 No package oniguruma found

在编译安装 PHP 7.4 时,如果使用 --with-mbstring 参数,则需要安装 oniguruma。oniguruma 是一个处理正则表达式库,php7.4 中,mbstring 正则表达式处理功能对这个包有依赖。所以,安装 php7.4 前需要安装 oniguruma 和 oniguruma-devel 两个软件包。 一般安装epel 然后安装即可: yum instal…
浏览: 80 标签:  ,  ,  , 

差点把博客升级挂了~

no zuo no die……手贱,yum -y update 更新了一下,接着把旧内核删除,重启……系统是正常启动了,博客刷新 502 Bad Gateway 了……艹……一直这个操作没出过事啊。再重启,问题依旧,懵了…… 执行 php -v 提示: php: error while loading shared libraries: libonig.so.2: cannot open shared object …
浏览: 143 标签:  ,  ,  , 

OneinStack php 7.3.12 升级 php 7.4.0

OneinStack 自带 php 升级脚本,不过目前并不支持从 php 7.3.12 升级到 php 7.4.0,不知道以后会不会支持。忍不住手动升级了,折腾前先备份一下。 备份当前版本 php which php ## 一般是 /usr/local/php/bin/php cp -r /usr/local/php /usr/local/php_bak 获取当前版本 php 配置参数 执…
浏览: 118 标签:  ,  , 

CentOS 8 体验 OneinStack 2.2 + PHP 7.4 + WordPress

OneinStack 2.2 发布,使用 shell 编写,可以快速在生产环境上部署 lnmp/lamp/lnmpa/lnmt(Linux、Nginx/Tengine/OpenResty、MySQL/MariaDB/Percona/MongoDB/PostgreSQL、PHP、Apache、Tomcat),适用于 CentOS 6~8(包括redhat)、Debian 6~10、Ubuntu 14~19 32位和64位系统。 OneinStack 包含工…
浏览: 62 标签:  ,  ,  ,  ,  ,  ,  ,  ,