LNMP 一键安装包 V1.6

最近比较忙,私密了几个标题还没闲心填坑。星期六,上班稍闲,水一篇刷刷存在感。 PHP 5.6.x 停止安全支持 2018年12月31日,PHP 5.6.x 安全支持正式停止。不过,2019.1.10 官方发布最后一个安全更新版本:PHP 5.6.40,如果没有发现严重漏洞,这将是 PHP 5 最后一个版本。(言下之意是可能还会更…
Tags:  ,  ,  ,  Views: 1.3K

LNMP 1.5 使用 OpenSSL 1.1.1 开启 TLSv1.3 支持

以前使用 OpenSSL 1.1.1 dev draft-18 开启过 TLSv1.3,那时候浏览器都得手工开启才支持 TLSv1.3,所以基本上纯属自娱自乐。八月份 TLS 1.3 正式发布,九月份 OpenSSL 1.1.1 正式版…… Chrome 70+ 版本默认开启 TLS 1.3 Final 支持;Firefox 63+ 也默认支持…… 博友 kn007 大佬折腾 TLS 1.3;可乐…
Tags:  ,  ,  ,  Views: 1.7K

本博客开始支持 TLS 1.3

TLS 1.3 目前只是 draft 版本,而支持 TLS 1.3 的 OpenSSL 1.1.1 的 draft-18 分支也只是开发者版本,所以,暂时最好不要用在生产环境。 其实前几天就折腾过 lnmp 1.4 升级 nginx 1.13.7,想顺手加上 TLS 1.3 支持,无奈折腾一圈以失败告终。 本博客开始支持 TLS 1.3 TLS 1.3 …
Tags:  ,  ,  ,  ,  Views: 7.8K

lnmp 1.4 更新至 nginx 1.12.2

lnmp 更新 nginx 还是挺方便的,执行 ./upgrade.sh nginx 然后输入 nginx 版本号就可以自动升级。nginx 升级为平滑升级,升级过程不影响 nginx 运行。 其实原本是折腾 TLSv1.3 的,网上看教程好像不难。比如,JerryQu 的本博客开始支持 TLS 1.3。 照着教程,结合 lnmp1.4,开启 TLSv1.3 并不难…
Tags:  ,  ,  ,  Views: 2.1K